Outage
Incident Report for PhotoDay
Resolved
We're back up and running! All systems now operational.
Posted Jul 21, 2023 - 08:23 EDT
Identified
We're currently experiencing an outage on the studio and customer sites - the issue has been identified and the team is working on resolving. Thank you for your patience!
Posted Jul 21, 2023 - 08:09 EDT
This incident affected: Customer Gallery (PhotoDay Customer Web) and Studio Dashboard (PhotoDay Studio Web).