Error on Digital Download Links
Incident Report for PhotoDay
Resolved
This incident has been resolved.
Posted Dec 08, 2023 - 12:53 EST
Identified
We are currently working on a fix for an issue that is preventing customers from downloading their digital purchases. Once resolved the images will be available on the original links sent via text and/or email.
Posted Dec 08, 2023 - 11:28 EST
This incident affected: Customer Gallery (Digital Download Links).