Gallery performance degradation
Incident Report for PhotoDay
Resolved
This incident has been resolved and gallery performance is stable.
Posted May 20, 2021 - 16:38 EDT
Monitoring
We've deployed some fixes and are seeing improvements in performance. Our team will continue to monitor performance throughout the evening into tomorrow.
Posted May 19, 2021 - 18:36 EDT
Identified
Customers may be experiencing some lag when accessing their gallery and viewing photos on the web and native apps. We've identified the issue and are working on a fix.
Posted May 19, 2021 - 15:20 EDT
This incident affected: Customer Gallery (PhotoDay Customer Web, Android App, iOS App).