Miller's Professional Imaging Outage
Incident Report for PhotoDay
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 16:11 EDT
Monitoring
Please note PhotoDay is NOT directly affected by the current Miller’s outage.

A message from Miller’s Lab - We are currently experiencing technical difficulties causing our website and web ordering platforms to be temporarily offline. It appears to be a cyber attack, which we are thoroughly investigating. We will keep you informed as we understand more about the scope of the outage.

How does this affect PhotoDay? Your customer’s transactions are processing as normal, and they are receiving receipts and confirmation of their orders. When Miller’s is back online, we will ensure all orders arrive and process accordingly and will post an update here.
Posted Aug 31, 2020 - 10:56 EDT
This incident affected: Labs (Lab - Miller's Professional Imaging).