Authentication Issues
Incident Report for PhotoDay
Resolved
This incident has been resolved. Our servers are operating normally now.
Posted Mar 22, 2019 - 11:32 EDT
Investigating
We’ve identified some unexpected errors when logging in our platform. We’ll be notifying you as soon as we have more information.
Posted Mar 22, 2019 - 11:10 EDT
This incident affected: Customer Gallery (PhotoDay Customer Web), Studio Dashboard (PhotoDay Studio Web), and iOS App, Android App.