DNS Server
Incident Report for PhotoDay
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 08:41 EDT
Identified
Experiencing uploads issue due to Amazon DNS errors.
Posted Oct 22, 2019 - 16:03 EDT
This incident affected: iOS App, Android App and Studio Dashboard (PhotoDay Studio Web).