Messages delay!
Incident Report for PhotoDay
Resolved
This incident has been resolved. SMS notifications are operating normally at this time.
Posted 7 months ago. Mar 06, 2019 - 09:48 EST
Investigating
All inbound and outbound MMS and SMS messages are experiencing delays of 15 minutes or more.
Posted 7 months ago. Mar 05, 2019 - 15:07 EST