SMS is down.
Incident Report for PhotoDay
Resolved
SMS service is up!
Posted May 29, 2019 - 11:25 EDT
Investigating
Inbound and outbound SMS messages are experiencing issues.
Posted May 29, 2019 - 11:14 EDT
This incident affected: SMS Notifications (CARRIER NETWORK - SMS Short Code, North America).