Mobile checkout
Incident Report for PhotoDay
Resolved
This incident has been resolved.
Posted Oct 02, 2019 - 11:22 EDT
Investigating
We are currently investing an issue that may be affecting the PhotoDay mobile apps on iOS and Android. This issue may affect a small amount of customers who are trying to checkout. While we continue to investigate, please direct customers who cannot checkout to view the gallery on the web. We'll provide additional information as soon as we can. Thanks.
Posted Sep 30, 2019 - 21:14 EDT
This incident affected: iOS App and Android App.