Degraded delivery of inbound and outbound shortcode MMS
Incident Report for PhotoDay
Resolved
Shortcode MMS delivery times are back to normal.
Posted 11 months ago. Oct 26, 2018 - 14:24 EDT
Investigating
We are investigating this issue.
Posted 11 months ago. Oct 26, 2018 - 14:21 EDT